侧边栏壁纸
  • 累计撰写 70 篇文章
  • 累计创建 140 个标签
  • 累计收到 25 条评论
标签搜索

目 录CONTENT

文章目录

[Stable Update] 关于Manjaro 12.20 升级问题

Faonecze
2022-12-21 / 1 评论 / 3 点赞 / 297 阅读 / 265 字 / 正在检测是否收录...
温馨提示:
本文最后更新于 2022-12-21,若内容或图片失效,请留言反馈。部分素材来自网络,若不小心影响到您的利益,请联系我们删除。

背景

今天(12.21)打开电脑,看到有更新,随手一个sudo pacman -Syyu,结果不出意外还是发生了一些意外…

案例

sudo pacman -Syyu

执行更新命令后,刚开始正常,但是结果很意外…

正在解析依赖关系...
正在查找软件包冲突...
错误:无法准备事务处理 (无法满足依赖关系)
:: 安装 db (6.2.32-1) 破坏依赖 'db=5.3.28' (lib32-db 需要) -> 安装软件库软件包时出错

处理方案

首先在Manjaro Linux CN社区寻求帮助,但是没有回应,可能大佬们没有遇到过,或者忙别的.

随后去Manjaro Forum浏览一圈发现有同样的朋友 url ,同时也看到有朋友回复了自己的处理方案 url

虽然自己也使用同样的处理方法,

sudo pacman -Rnc lib32-db

20221221123938

20221221124009

这样就可以正常的升级了…

扩展链接

lib32-db - lib32-db 5.3.28-5 has been removed from the [multilib] repository. | Package lib32-db is out of date.

3
广告 广告

评论区